Przyszłość REST API

Ostatnio dostaliśmy komunikat z Allegro, który mówi konieczności zaktualizowania TLS po stronie serwera i możliwych konsekwencjach przy zaniechaniu tej czynności.

Używasz na serwerze protokołu szyfrowania danych jedynie w wersji TLS 1.0.

TLS (ang. Transport Layer Security) zapewnia poufność i integralność transmisji danych. Wersja 1.0 powstała w 1999 roku i nie spełnia już dzisiejszych standardów bezpieczeństwa.

Zaktualizuj oprogramowanie na serwerze i połącz się z Allegro za pomocą protokołu TLS 1.1 lub 1.2. Więcej na ten temat znajdziesz na stronie Protokół TLS na Twoim serwerze-instrukcja.

  • Po 31 maja: stracisz możliwość pobierania, tworzenia i edycji danych po API Allegro. Jeśli wyślesz request z takiego serwera, to otrzymasz komunikat błędu, że używasz przestarzałej wersji protokołu TLS. Pełne wersje komunikatów znajdziesz tutaj.
  • Po 30 czerwca: nie będziesz mógł nawiązać połączenia z API Allegro.

Zaktualizowałem kod klienta, jednak na razie nie mam pewności, czy zadziała.

Otóż serwis powstał w czasach, gdy oficjalne REST API nie istniało.
Nowe API jest co prawda jeszcze w trakcie tworzenia, ale nie zmienia to faktu, że przyszłość naszej usługi jest pod znakiem zapytania.

Nie poświęcałem serwisowi dużo czasu, nie aktualizowałem, nie obserwowałem zmian oficjalnego API, nie rozwijałem, dlatego zalecam korzystanie z oficjalnego API Allegro.

Jeśli 31 maja wszystko będzie działało, zostawię serwis w aktualnym stanie, ale należy się liczyć z tym, że usługa może zostać w końcu zawieszona.

Comments are closed.